2017 was our 20th year online!

Welcome to the Piano World Piano Forums
Over 3 million posts about pianos, digital pianos, and all types of keyboard instruments.
Over 100,000 members from around the world.
Join the World's Largest Community of Piano Lovers (it's free)
It's Fun to Play the Piano ... Please Pass It On!

Shop our online store for music lovers
SEARCH
Piano Forums & Piano World
(ad)
Best of Piano Buyer
 Best of Piano Buyer
(ad)
Faust Harrison Pianos
Faust Harrison 100+ Steinway pianos
(ad)
Wessell Nickel & Gross
PianoForAll
Who's Online Now
79 members (anotherscott, Brendan, alexdavid, BerndAB, andrea monza, accordeur, Ben Crosland, 14 invisible), 1,281 guests, and 534 robots.
Key: Admin, Global Mod, Mod
(ad)
Estonia Pianos
Estonia Pianos
Previous Thread
Next Thread
Print Thread
Hop To
Joined: Mar 2020
Posts: 98
Chummy Offline OP
Full Member
OP Offline
Full Member
Joined: Mar 2020
Posts: 98
Hi Forum and Kawai James, hopefully you read this

First I'd like to report another bug. I'm not 100% sure but I believe it started after the update to the newest version (the one that fixed the annoying pedal bug in dual mode) , however don't quote me on that if it turns out this was present from v 1.0.

The Bug: When switching between sounds, the sound jumps to the first default sound (SK PIANO) instead of what's been selected.

More Description: When I'm playing a sound from one of the categories (for the sake of example, let's say I'm playing an organ patch) and then I'd like to go to another category (for example, "EP") I press the circled button of the EP category but the sound is jumped to the first default sound "SK Concert Piano" of the first acoustic piano category as also denoted on the screen, even though the button pressed was of the "EP category". In order to get to the EP category another press of the EP is needed after noticing the misbehaviour.


This type of bug (sound switching jumps to default sound) has occured many times throughout my playing with the ES920. This is annoying due to not being able to predict WHEN it happens. I just went to my ES920 to try to recreate this bug and somehow it happened ONCE but I can't seem to recreate the bug at will and while playing an important gig if I need to quickly switch a sound during a song I might find myself playing the default piano sound when in fact I chose a different sound. Not sure if this also affects user presets but this should be verified by KAWAI to make sure it doesn't. I'm pretty sure this bug also happened to me when using the VALUE (sound +/- 1) buttons to go to the next/previous sound when instead I got jumped to the default piano.

Now, this doesn't happen at all when I quickly scroll through with the category or value buttons to go between sounds. I haven't timed how much wait time between singular program changes this bug occurs but when you're playing some songs/pieces it could take several minutes, time passes lol. I don't know whether other factors affect this, such as key presses, pedal hold. etc. (Program change is also MIDI related) and since I have no knowledge of how the KAWAI ES920 software works, I can't diagnose and debug this correctly.

Please please KAWAI team take notice of this and check the software for the cause of this and fix.

-------------

Now for a question: Does the ES920 transmit aftertouch? of course it doesn't have it's own aftertouch strip, but if I use a hardware/software synth that has aftertouch settings, can the aftertouch work via MIDI?


Thanks!!!

Joined: Sep 2007
Posts: 17,675
Yikes! 10000 Post Club Member
Offline
Yikes! 10000 Post Club Member
Joined: Sep 2007
Posts: 17,675
Hello Chummy,

Originally Posted by Chummy
Kawai James, hopefully you read this...

Yes, I've read your post, however it's usually more polite better to just send a PM directly.

Originally Posted by Chummy
First I'd like to report another bug.

Okay, I would recommend taking one of the following steps:

1. Send me a PM.
2. Contact my colleague at Kawai America who assisted you with the pedal bug reported previously.
3. Contact Kawai Japan by sending a message via the enquiry form on the Kawai Global website.

Thank you! wink

Originally Posted by Chummy
The Bug: When switching between sounds, the sound jumps to the first default sound (SK PIANO) instead of what's been selected.

If you are able to reproduce this behaviour consistently (i.e. the SK Concert Grand sound is selected every time you press a sound button), it's likely a bug. However, if not, it could be caused by something else.

Originally Posted by Chummy
Now for a question: Does the ES920 transmit aftertouch? of course it doesn't have it's own aftertouch strip, but if I use a hardware/software synth that has aftertouch settings, can the aftertouch work via MIDI?

According to the MIDI Implementation Chart the ES920 does not transmit nor receive aftertouch data. Just out of curosity, given that the ES920's action does not have any kind of aftertouch functionality, what kind of aftertouch MIDI data would it send?

Kind regards,
James
x


Employed by Kawai Japan, however the opinions I express are my own.
Nord Electro 3 & occasional rare groove player.
Joined: Mar 2020
Posts: 98
Chummy Offline OP
Full Member
OP Offline
Full Member
Joined: Mar 2020
Posts: 98
Quote
Yes, I've read your post, however it's usually more polite better to just send a PM directly.

"More polite"? what a strange response... anyway, the point of of other users seeing this post is self explanatory: maybe someone managed to find out what causes this or can contribute additional info in the hopes of helping KAWAI solve this. (forums in general are a good place to find solutions using mass knowledge). What would you like for me to write you in the PM?

[/quote]Okay, I would recommend taking one of the following steps:

1. Send me a PM.
2. Contact my colleague at Kawai America who assisted you with the pedal bug reported previously.
3. Contact Kawai Japan by sending a message via the enquiry form on the Kawai Global website.

Thank you![/quote]


Thank you for the advice. Just done number 2 and 3. Sent both to Alan and an Enquiry form to KAWAI Global.

Quote
According to the MIDI Implementation Chart the ES920 does not transmit nor receive aftertouch data. Just out of curosity, given that the ES920's action does not have any kind of aftertouch functionality, what kind of aftertouch MIDI data would it send?

Kind regards,
James
x

Oh my bad.. I was thinking about two different things while writing and my mind wandered. Yeah it wouldn't work with an external synth since the keyboard has nothing on it. I was thinking by mistake of some keyboards' ability to receive aftertouch data from DAW regarding their built in sounds and mistakenly applied it to external sounds too. Sometimes when you really wish things to work, you just think like that haha.

Quote
f you are able to reproduce this behaviour consistently (i.e. the SK Concert Grand sound is selected every time you press a sound button), it's likely a bug. However, if not, it could be caused by something else.

a 100% software issue. I've been a programmer of such stuff, notably in MAX language and MSP, and have built software sequencers, samplers and other tools etc. to be able to recognize such issue as presented by the behavior of my ES920 unit.

Joined: Mar 2020
Posts: 98
Chummy Offline OP
Full Member
OP Offline
Full Member
Joined: Mar 2020
Posts: 98
BTW - important info! before I updated my KAWAI ES920 to the current latest version (v1.11) I installed a BETA update file sent only to me by the American rep. the official 1.11 version (can't know for sure if these were the same files or not in retrospect) appeared on the KAWAI site only a couple of weeks later and I decided to install it on top of the BETA update I already did. This may or may not be a factor affecting the bug and I am most likely the only person in the world who did this.

I just thought about this after already having sent the letter to KAWAI reps in Japan and US. However, I sent them BOTH a link to this thread, precisely for the purpose of following the developments of information so hopefully they do read on.

Last edited by Chummy; 09/17/21 01:17 AM.
Joined: Sep 2007
Posts: 17,675
Yikes! 10000 Post Club Member
Offline
Yikes! 10000 Post Club Member
Joined: Sep 2007
Posts: 17,675
Originally Posted by Chummy
a 100% software issue.

So to clarify, this mean that...

Originally Posted by myself
...you are able to reproduce this behaviour consistently (i.e. the SK Concert Grand sound is selected every time you press a sound button)

Correct?

Kind regards,
James
x


Employed by Kawai Japan, however the opinions I express are my own.
Nord Electro 3 & occasional rare groove player.
Joined: Apr 2019
Posts: 1,314
A
1000 Post Club Member
Offline
1000 Post Club Member
A
Joined: Apr 2019
Posts: 1,314
Originally Posted by Kawai James
...
Yes, I've read your post, however it's usually more polite better to just send a PM directly
...

Are we talking to the supreme leader or the grand ayatollah or something here?


Kawai MP7SE, Yamaha MOTF XF6, Yamaha WX5, Yamaha Pacifica 112v
Joined: Mar 2020
Posts: 98
Chummy Offline OP
Full Member
OP Offline
Full Member
Joined: Mar 2020
Posts: 98
Originally Posted by Kawai James
Originally Posted by Chummy
a 100% software issue.

So to clarify, this mean that...

Originally Posted by myself
...you are able to reproduce this behaviour consistently (i.e. the SK Concert Grand sound is selected every time you press a sound button)

Correct?

Kind regards,
James
x

This happens pretty often, meaning most of my sessions with my ES920 it happens at least once. Obviously if it happened only once or twice a year I wouldn't have thought much about it nor I'd remember this is a thing probably... but I find it hard to determine what causes this nevertheless since I have no access to the software, not knowledge of how it is programmed and there are way too many contributing factors to be able to do proper diagnosis. I WILL try to video film it just like the last bug I caught, it may take me a couple of days since I'm a bit on the busy side right now. Hopefully I can catch it and post an update in this thread.

Joined: Sep 2007
Posts: 17,675
Yikes! 10000 Post Club Member
Offline
Yikes! 10000 Post Club Member
Joined: Sep 2007
Posts: 17,675
Originally Posted by Chummy
This happens pretty often, meaning most of my sessions with my ES920 it happens at least once.

Thank you for the additional information.

So, if a session lasts... let's say 1 hour, and this phenomenon occurs at least once...would that be an accurate description of the occurrence frequency (once an hour)?

The ES920 v1.11 software update was released in April, and this model is quite popular, so I would have expected more users to have encountered this phenomenon if it is indeed a software bug that affects all instruments running v1.11.

Do you have any other devices connected to your ES920, aside from the included F-10H damper pedal?

Originally Posted by Chummy
I WILL try to video film...

Thank you. Any additional information that helps to reliably reproduce this phenomenon will also be useful.

Kind regards,
James
x


Employed by Kawai Japan, however the opinions I express are my own.
Nord Electro 3 & occasional rare groove player.
Joined: Mar 2020
Posts: 98
Chummy Offline OP
Full Member
OP Offline
Full Member
Joined: Mar 2020
Posts: 98
Here's a video of the bug I created (link to YouTube):   


 I wrote some further important details in the video description in which I also copy here below:


Quote
This bug jumps the sound when switching to the default "SK piano" even though the selected sound should be other.

It happens BOTH with the "Value" Button and the "Category button". The video depicts an example of it happening with the "Value" Button.

This bug occurs RARELY and I couldn't replicate it at will. I sat playing/messing around for about 45 minutes with a camera on near the piano and it happened only ONCE. Usually it happens once every few hours of play on average. The bug can and does happen when NO note or sustain pedal is held, just making sure to state that in case one would think otherwise from the video as it doesn't show the pedal.

The ES920 is latest version 1.11, NO MIDI or USBs are connected to it whatsoever. Only Headphones, KAWAI supplied sustain pedal and POWER cable.


This mail + video was sent to KAWAI US rep. I will keep you guys informed of any developments in follow up messages in this thread.
Cheers!

Joined: Mar 2020
Posts: 98
Chummy Offline OP
Full Member
OP Offline
Full Member
Joined: Mar 2020
Posts: 98
@Kawai James

Yeah in my last post I said "often" and in my current post I said "rarely".

and TBH, it sort of happens once and hour or every few hours.. and even that is a super rough estimation because I don't have a scientifically accurate idea. Terms such as "often" and "rarely" are relative and are affected by feeling.

I have definitely encountered it many times for it to be a "thing", that's for 100%. I tried getting a second video with the bug happening using the "Category button" but couldn't. Funnily enough, when writing the original post in this thread I went to my ES920 and it happened with the category button, and I was so disappointed I didn't have it on tape. I might try to get that one sometime, but after an hour messing around that's a lot of wasted time for me... which I can't afford. Hopefully whatever I did will be enough^^

Joined: Sep 2007
Posts: 17,675
Yikes! 10000 Post Club Member
Offline
Yikes! 10000 Post Club Member
Joined: Sep 2007
Posts: 17,675
Hello Chummy,

Thank you for uploading the video.

I discussed this topic with one of my colleagues at Kawai America whom I believe you are already in contact with. Hopefully you will be able to get to the bottom of this one.

Kind regards,
James
x


Employed by Kawai Japan, however the opinions I express are my own.
Nord Electro 3 & occasional rare groove player.
Joined: Mar 2020
Posts: 98
Chummy Offline OP
Full Member
OP Offline
Full Member
Joined: Mar 2020
Posts: 98
UPDATE: After talks with Kawai US the team in Japan once again released a BETA update (1.12a) for me to install. The update FIXES the bug!
a diagnosis has been also made by Kawai team: The bug is caused when being in dual mode (one of the sounds should not be the default SK piano) , then switching to a single sound (you can then toggle to however many single sounds you want) and then pressing the value +/- button. The sound will jump back to the default SK piano rather than increasing/decreasing the sound selection by 1, as should be expected when using the "value" button.

I assume this update will be available to the public soon, following its success

I should apply to work at KAWAI at this rate haha :-)

Regards
Chummy

Joined: Sep 2007
Posts: 17,675
Yikes! 10000 Post Club Member
Offline
Yikes! 10000 Post Club Member
Joined: Sep 2007
Posts: 17,675
Hello Chummy,

Thank you for sharing this positive outcome with the rest of the forum.

We were not able to reproduce the sound category button bug that you initially reported. However, as you note, my colleague in the US was able to reproduce a similar issue that could occur when the value buttons are pushed under certain conditions (as per your example video), which has been fixed.

I don't know when this fix will be made publicly available, however if anyone else is experiencing this issue and would also like to receive the beta version, please feel free to send me a PM.

Kind regards,
James
x


Employed by Kawai Japan, however the opinions I express are my own.
Nord Electro 3 & occasional rare groove player.

Moderated by  Piano World 

Link Copied to Clipboard
What's Hot!!
Pianos - Organs - & Keyboards, Oh My!
Our Fall 2021 Free Newsletter is Out , see it here!
---------------------
Selling my Hammond & Leslie!
---------------------
My first professionally recorded piece
---------------------
Visit Maine, Meet Mr. Piano World
---------------------
Posting Pictures on the Forums
-------------------
Forums RULES & HELP
-------------------
ADVERTISE on Piano World
(ad)
Pianoteq
Steinway Spiro Layering
(ad)
PianoDisc

PianoDisc
(ad)
Piano Life Saver - Dampp Chaser
Dampp Chaser Piano Life Saver
(ad)
Mason & Hamlin Pianos
New Topics - Multiple Forums
New Yamaha CFX- Production voices
by newer player - 10/18/21 07:21 PM
What books do you use to teach music theory to beginners?
by chicagopiano1 - 10/18/21 06:13 PM
Kawai NV5 Hissing Sound
by Kend - 10/18/21 05:58 PM
Not a game but can be played
by FrankCox - 10/18/21 04:53 PM
Steve Droy - Piano Technology school (England)
by Tatum125s - 10/18/21 01:45 PM
Download Sheet Music
Virtual Sheet Music - Classical Sheet Music Downloads
Forum Statistics
Forums42
Topics209,646
Posts3,140,553
Members103,043
Most Online15,252
Mar 21st, 2010
Please Support Our Advertisers

Faust Harrison 100+ Steinways

Dampp Chaser Piano Life Saver

 Best of Piano Buyer

PianoTeq Bechstein
Visit our online store for gifts for music lovers

Virtual Sheet Music - Classical Sheet Music Downloads



 
Help keep the forums up and running with a donation, any amount is appreciated!
Or by becoming a Subscribing member! Thank-you.
Donate   Subscribe
 
Our Piano Related Classified Ads
| Dealers | Tuners | Lessons | Movers | Restorations | Pianos For Sale | Sell Your Piano |

Advertise on Piano World
| Subscribe | Piano World | PianoSupplies.com | Advertise on Piano World |
| |Contact | Privacy | Legal | About Us | Site Map | Free Newsletter | MapleStreetMusicShop.com - Our store in Cornish Maine


© copyright 1997 - 2021 Piano World ® all rights reserved
No part of this site may be reproduced without prior written permission
Powered by UBB.threads™ PHP Forum Software 7.7.5